sábado, 2 de octubre de 2010

PROTOCOLOS DE INTERNET

¿Cómo funciona Internet?
Internet es una red formada por miles de redes independientes pertenecientes a instituciones públicas, centros de investigación, empresas privadas y otras organizaciones. Las normas que aseguran la comunicación entre las redes son los denominados protocolos de internet.


¿Qué protocolos existen?
Hay diversos protocolos dependiendo del tipo de comunicación que se establece entre las máquinas. El protocolo HTTP (HyperText Transfer Protocol) es la base de la web, también está el FTP (File Transfer Protocol) para transferencia de archivos o el SMTP y POP para correo.


¿Qué es la web?
La web es un sistema que facilita el acceso a los distintos recursos que ofrece internet a través de una interfaz común basada en el hipertexto. La web se ha hecho enormemente popular con la aparición de unos programas dotados de interfaces gráficas amigables que permiten a cualquier persona acceder a los documentos de la red: son los conocidos navegadores.

PROTOCOLOS DE INTERNET 2

§1 Sinopsis
En la sección 3.1 hemos señalado que las comunicaciones Internet se denominan también comunicaciones TCP/IP debido al nombre de dos de los protocolos más significativos que utilizan, pero que estos no son los únicos. A fin de que el lector pueda tener una idea aproximada de su misión y significado, a continuación se muestra una selección de los más usuales.

§2 Internet Protocol (IP)
Ya hemos señalado que es uno de los protocolos fundamentales de Internet. En el modelo OSI ( 3.1) pertenece a la denominada subcapa de transporte dentro de la capa de Red. Absolutamente todas las aplicaciones de Internet deben usar este protocolo cuya especificación está contenida en RFC 791.

Entre sus responsabilidades se encuentra fragmentar los datos a transmitir que han sido recibidos de la capa superior (de Transporte) en trozos denominados datagramas IP. Estos datagramas son entregados a la capa inferior (de Enlace) donde son empaquetados en cuadros ("Frames") y entregados a la capa que se encarga de controlar el medio físico sobre el que se efectúa la transmisión (capa Física). El proceso es exactamente inverso para los paquetes recibidos. La tabla adjunta muestra el esquema interno de un datagrama IP (tamaño T del campo en bits).

Campo
T
Descripción

VERS
4
Versión de IP utilizada para la creación del datagrama

datagrama

HLEN
4
Longitud de la cabecera (palabras de 32 bits)

SERVICE TYPE
8
Indicador de servicio. Especifica como debe ser interpretado

TOTAL LENGTH
16
Longitud total del datagrama (bytes) [3]

IDENTIFICATION
16
Número generado por el remitente que asegura el correcto ensamblado por el receptor

FLAGS
3
Distintos indicadores. Por ejemplo MORE FLAGS, que indica si el campo ha sido fragmentado (es una porción de un un todo).

FRAGMENT OFFSET
13
Si es un trozo de algo fragmentado, señala la posición del fragmento en el total [4].

TIME TO LIVE
8
Cuantos saltos se espera que viva el datagrama antes de ser destruido, si no ha alcanzado su destino

PROTOCOL
8
Señala el protocolo de alto nivel al que corresponden los datos en la porción de datos del datagrama.

HEADER CHECKSUM
16
Suma de control de la cabecera. Es comprobada en cada punto donde el datagrama es procesado.

SOURCE ADDRESS
32
Dirección IP del remitente

DESTINATION ADDRESS
32
Dirección IP del destinatario.

OPTIONS
Variable
Zona reservada para uso diverso. Generalmente utilidades de chequeo y depuración.

PADDING
Variable
Cierta cantidad de ceros necesarios para que el tamaño de la cabecera sea un múltiplo de 32 bits.



Otra responsabilidad de este protocolo es decidir el camino más adecuado para los datagramas en caso que haya más de uno disponible. Esto es conocido como enrutado ("Routing").

Una característica distintiva de éste protocolo es que cada paquete es enviado como si fuese una entidad independiente de las demás. De forma que IP no mantiene ningún control sobre los detalles de la conexión entre las máquinas que dialogan (el cliente y el servidor). Tampoco garantiza que la transmisión se realice con éxito. Esta función es encomendada a otros protocolos de la cadena.

§3 Internet Control Message Protocol (ICMP)
Es un protocolo que podíamos denominar "auxiliar" de la transmisión, ya que está más orientado a la calidad de la transmisión que a la transmisión en sí misma. Es responsable de generar mensajes cuando ocurren errores en la transmisión. También puede generar mensajes de prueba e informativos sobre la transmisión, incluyendo un modo especial de eco que puede manejarse mediante PING ("Packet Internetwork Goper" Ap.C)

§4 Internet Group Management Protocol (IGMP)
El protocolo IGMP funciona como una extensión del protocolo IP. Se emplea para realizar IP multicast, es decir, cuando el envío de datos a una dirección IP puede alcanzar múltiples servidores de una red y/o a todas las máquinas de una subred. Además de utilizarse para pasar información se utiliza para establecer los miembros de la red, pasar información de los miembros y establecer rutas. Otros muchos protocolos hacen uso de las funciones IGMP dentro de sus especificaciones.

§5 Gateway-to-Gateway Protocol (GGP)
.

§6 Transmission Control Protocol (TCP)
.

§7 Exterior Gateway Protocol (EGP)
.

§8 Interior Gateway Protocol (IGP)
.

§9 User Datagram Protocol (UDP)
Protocolo para transmisiones que pueden permitirse ciertos errores (pérdida de paquetes) a cambio de un incremento en la velocidad. Es aplicado en transmisiones de Video en tiempo real (por ejemplo RealPlayer) que ignora los marcos erróneos y en otras comunicaciones Internet como DNS. Ofrece mucho menos control que TCP , por lo que también ha sido descrito como "Unreliable Datagram Protocol". No puede garantizar el orden de llegada de los paquetes ni tampoco la llegada en sí, sin embargo garantiza menor tiempo de respuesta que TCP. Está descrito en RFC 768.

§10 Dynamic Host Configuration Protocol (DHCP)
Este protocolo permite simplificar la administración de grandes redes IP, permitiendo que los equipos individuales de una red puedan obtener sus datos de configuración desde un servidor especial (servidor DHCP), en especial en aquellas redes en las que no se tiene información exacta sobre los equipos individuales hasta que estos no recaban la información. Es el caso típico de muchos proveedores de servicios de Internet (ISPs) y de redes a las que se conectan portátiles o empleados de forma remota ( 3.6).

§11 HiperText Transfer Protocol (HTTP)
Es el protocolo utilizado para transmitir las páginas Web escritas en lenguaje de marcas de hipertexto HTML ("Hyper Text Markup Languaje" 5.2).

§12 Simple Mail Transfer Protocol (SMTP)
Protocolo encargado de transmitir los mensajes de correo de un servidor a otro. Una vez que los mensajes están en el servidor de destino se utiliza otro protocolo (POP ) para llevarlo a la máquina del cliente final.

§13 Post Office Protocol (POP)
Es el protocolo que permite a un usuario leer el correo que llega a su servidor. Es un protocolo para las comunicaciones Servidor a Usuario. No confundir con SMTP que es un protocolo para transmisiones entre servidores.

Existen tres versiones: POP, POP2, y POP3. Cuando recibimos un e-mail queda almacenado en el servidor hasta que conectamos con él mediante el cliente de correo (un programa) y nos autentificamos (proporcionamos un nombre de usuario y contraseña correctos). Después de esto POP es utilizado para transferir los datos desde el servidor al buzón de correo entrante de nuestra propia máquina. Eventualmente una vez recibida la copia es posible ordenar al servidor que borre los ficheros originales.

Existe otro protocolo que permite manejar el correo en el servidor. Es IMAP (ver), cuya diferencia fundamental con POP es que este último se limita a pasar los mensajes al cliente autenticado, mientras que IMAP pone el control del correo electrónico en manos del servidor.

POP3S es el protocolo de cifrado POP3 mediante SSL ("Secure Sockets Layer").

Nota: SSL es un protocolo propuesto en 1994 por Netscape Communications junto con la primera versión de su navegador Navigator. A pesar de que últimamente se le han encontrado algunas vulnerabilidades, es la opción implantada en la mayoría de servidores Web que requieren sistema de seguridad. Por ejemplo, servicios de comercio o correo electrónico seguros o controlar accesos a servicios de pago basados en la Web. Utiliza un sistema de cifrado y descifrado de datos RSA de clave pública [1]. Mas información en: 6.4 Cifrado y firmas digitales. N.14 El sistema RSA y los intentos para descifrarlo. N.17 La seguridad del Sistema RSA; estado de la cuestión.

§14 File Transfer Protocol (FTP)
El protocolo FTP es uno de los más utilizados en Internet, ya que permite transferir ficheros entre dos máquinas utilizando una conexión Internet. El protocolo dispone de una serie de formas estandarizadas por las que una máquina remota puede crear y cambiar directorios en la máquina local, así como transferir, copiar, mover y borrar ficheros. En realidad FTP utiliza comandos de texto plano para indicar las diversas órdenes, pero existen multitud de programas que simplifican su utilización mediante una interfaz gráfica en la que las operaciones de transferencia se reducen a procesos de cortar y pegar y en las que recorrer el árbol de directorios de la máquina remota es tan fácil como utilizar el navegador en la propia máquina.

Más información en: 8.2 FTP Transferencia de ficheros.

§15 Point to Point Protocol (PPP)
Un protocolo utilizado para enviar paquetes punto-a-punto sobre líneas serie. Es uno de los más utilizados, ya que soporta las comunicaciones sobre líneas telefónicas a través de módem (el módem utiliza una conexión serie). Permite utilizar sobre él otros protocolos de más alto nivel (más cercanos a la capa de Aplicación), como IPX/SPX y TCP/IP. Cuando la comunicación es a través de línea telefónica, pero en vez de ser convencional (RTB) es ADSL ( 7.2), se utiliza una variedad denominada PPPoE (PPP over Ethernet).

PPP también puede ser utilizado sobre conexiones de red distintas de las telefónicas. Windows lo instala cuando se instala un módem o servicio de RAS [2]. Una versión antigua de este protocolo que se utilizaba exclusivamente para conectar a servidores Unix de acceso remoto se denomina SLIP ("Seriar Line IP").

§16 Network News Transfer Protocol (NNTP)
Este protocolo, Creado en 1986 Kantor y Lampsley y descrito en RFC 977, es utilizado para distribuir en Internet un tipo especial de mensajes denominados noticias ("News") entre unas máquinas configuradas como servidores y los clientes (los lectores de las noticias). El sistema constituye un servicio que transfiere diariamente millones de mensajes clasificados por temas denominado Usenet ( 8.4), y cuya importancia en cuanto a la comunicación de ideas y opiniones es solo comparable al servicio de e-mail.

El formato de las noticias (muy parecido al de e-mail), fue definido en RFC 850 por Mark Horton. La versión actual está descrita en RFC 1036. Su diferencia conceptual más importante respecto al e-mail es que en éste, el mensaje es accesible únicamente por su destinatario, mientras que los mensajes de Usenet aparecen en un tablón de anuncios accesible por todos.

NNTP proporciona distribución, consulta, recuperación y exposición de "News" mediante el uso de una transmisión confiable basada en secuencias de noticias relacionadas. NNTP está diseñado de forma que las noticias se almacenan en una base de datos centralizada en un servidor, de manera que los usuarios pueden seleccionar elementos específicos que leer. También se proporciona indización, las referencias cruzadas y la caducidad de mensajes antiguos.

§17 Protocolos de encaminamiento
Son utilizados por herramientas auxiliares cuyo fin último es construir las tablas de ruta ( Ap. A) de los encaminadores ("Routers"). Esta función puede ser realizada manualmente en caso de redes pequeñas, pero es una tarea muy ardua en caso de redes medianas, e imposible en caso de redes extensas (Internet), ya que la tabla de ruta depende de la topología de la red, y esta puede cambiar con relativa frecuencia. Por esta razón, los routers utilizan algoritmos que realizan el análisis de forma automática intercambiando información con otros routers.

Existen varios de estos protocolos según se trate de construir las tablas de redes privadas o externas (Internet). Los primeros son denominados protocolos de enrutamiento interno, el más importante de los cuales es RIP ("Routing Information Protocol") definido en la RFC 1058. Sin embargo es bastante ineficiente porque exige a los routers intercambiar periódicamente tablas completas. Actualmente está siendo reemplazado por OSPF ("Open Shortest Path First") definido en RFC 1583 que es más eficiente.

Para las tablas entre redes independientes se utilizan los protocolos de enrutamiento externo, como EGP ("External Gateway Protocol") y BGP ("Border Gateway Protocol") definido en RFC 1771.

§18 Webografía
Si quiere profundizar el los aspectos técnicos de las comunicaciones IP, la Web de Cisco Systems (líder mundial en fabricación de quipos para comunicación IP) es una fuente inagotable de información.

•Cisco Systems Technology Support www.cisco.com/

VOZ SOBRE PROTOCOLO DE INTERNET

1. Introducción
En el presente artículo damos a conocer información sobre la telefonía VoIP ( Voz transmitida sobre Protocolo de Internet ), la cual permite a los usuarios realizar llamadas de voz y fax sobre conexiones IP ( Internet, Intranets, etc. ).

La Voz transmitida sobre IP ( VoIP ), ya ha estado presente por mucho tiempo en el mercado, pero la aparición de nuevos e innovadores servicios en esta tecnología han hecho realidad la integración de datos y voz, lo cual significa para muchas empresas un ahorro de costos y que las comunicaciones sean más eficientes y efectivas.
2. Definición
La VoIP ( Voz transmitida sobre Protocolo de Internet ) es una tecnología nueva que permite la transmisión de la voz a través de redes IP (Protocolo de Internet) en forma de paquetes de datos.

La VoIP ( Voice over Internet Protocol ) denominada así por sus siglas en inglés, lo que significa Voz transmitida sobre Protocolo de Internet, esta industria se encuentra en una etapa de crecimiento muy rápido, es un hecho que en el año 2010 una gran parte de las llamadas mundiales se basaran en IP ( Protocolo de Internet ).

La Voz transmitida sobre IP es una tecnología que puede ser habilitada mediante una red de datos de conmutación de paquetes, vía el protocolo IP ( Protocolo de Internet ), una importante ventaja de esta tecnología es la transmisión de voz de manera gratuita, ya que esta información viaja a través de la red como datos.

La tecnología de telefonía VoIP (Voz transmitida sobre Protocolo de Internet ) ofrece lo siguiente:

- Acceso a redes corporativas a través de redes integradas de voz y datos.

- Servicios de directorio y de conferencias realizadas en gráficos mediante un sistema llamado sistema de sobremesa.

- Directorios corporativos (Intranet ), con servicio de mensajes.

- Redes Privadas Virtuales y Gateways Virtuales para voz.




[editar]

3. Elementos de la VoIP ( Voz transmitida sobre IP )
a. El cliente

El cliente establece y termina las llamadas realizadas de voz, esta información se codifica, se empaqueta y se transmite a través del micrófono (entrada de información ) del usuario, de la misma forma la información se decodifica y reproduce a través de los altavoces o audifonos (salida de la información).

b. Los Servidores

Los servidores se encargan de manejar operaciones de base de datos, realizado en un tiempo real como en uno fuera de él. Entre estas operaciones se tienen la contabilidad, la recolección, el enrutamiento, la administración y control del servicio, el registro de los usuarios, etc.


c. Los Gateways

Los Gateways brindan un puente de comunicación entre todos los usuarios, su función principal es la de proveer interfaces con la telefonía tradicional adecuada, la cual funcionara como una plataforma para los usuarios (clientes) virtuales.

[editar]

4. Características de VoIP ( Voz transmitida sobre IP )
- VoIP nos permite el control del tráfico que existe en la red.

- Proporciona un enlace a la red de telefonía tradicional.

- Permite una integración con grandes redes de IP ( Protocolo de Internet ) actuales, ya que es independiente en su tipo de red física.




[editar]

5. Ventajas de VoIP
- Una importante ventaja es que no hay que pagarle a las compañías telefónicas por la comunicación.

- Tiene integración sobre la Intranet de la voz como cualquier servicio de la red.

- Existe interoperabilidad de diversos proveedores.

- Tiene independencia en las tecnologías de transporte.

- Tiene menores costos que otras tecnologías.

- VoIP no paga la tarifa de llamadas larga distancia.

[editar]

6. Desventajas de VoIP
- Una desventaja importante es la calidad de la transmisión es un poco inferior a la telefónica, ya que los datos viajan en forma de paquetes, es por eso que se puede tener algunas perdidas de información y demora en la transmisión.

- El problema en si de la VoIP, no es el protocolo si no la red IP, ya que esta no fue pensada para dar algún tipo de garantías.

- Otra desventaja es la latencia , ya que cuando el usuario está hablando y otro usuario está escuchando, no es adecuado tener 200ms (microsegundos) de pausa en la transmisión.

- Cuando se va a utilizar VoIP, se debe controlar el uso de la red para garantizar una transmisión de calidad.

V0Z SOBRE IP

Voz sobre Protocolo de Internet, también llamado Voz IP, VozIP, VoIP (por sus siglas en inglés), es un grupo de recursos que hacen posible que la señal de voz viaje a través de Internet empleando un protocolo IP (Protocolo de Internet). Esto significa que se envía la señal de voz en forma digital, en paquetes, en lugar de enviarla en forma analógica, a través de circuitos utilizables sólo para telefonía como una compañía telefónica convencional o PSTN (sigla de Public Switched Telephone Network, Red Telefónica Pública Conmutada).

Los Protocolos que se usan para enviar las señales de voz sobre la red IP se conocen como protocolos de Voz sobre IP o protocolos IP. Estos pueden verse como aplicaciones comerciales de la "Red experimental de Protocolo de Voz" (1973), inventada por ARPANET.

El tráfico de Voz sobre IP puede circular por cualquier red IP, incluyendo aquellas conectadas a Internet, como por ejemplo las redes de área local (LAN).

Es muy importante diferenciar entre Voz sobre IP (VoIP) y Telefonía sobre IP.

VoIP es el conjunto de normas, dispositivos, protocolos, en definitiva la tecnología que permite comunicar voz sobre el protocolo IP.
Telefonía sobre IP es el servicio telefónico disponible al público, por tanto con numeración E.164, realizado con tecnología de VoIP.

25 AÑOS DEL PROTCOLO TCP/IP

Los protocolos usados en TCP/IP unicamente usados en capas 2 y 3 Acaban de cumplirse 25 años de la transición definitiva de ARPANET a la familia de protocolos de TCP/IP. Este hecho, producido el 1 de enero de 1983, se menciona en el artículo Historia de Internet y existen fuentes en Internet que lo corroboran. Los protocolos en sí son un poco más antiguos. Concretamente, las especificaciones de IP y TCP se publicaron en septiembre de 1981 como RFC 791 y RFC 793.

VENTAJS E INCONVENIENTES

El conjunto TCP/IP está diseñado para enrutar y tiene un grado muy elevado de fiabilidad, es adecuado para redes grandes y medianas, así como en redes empresariales. Se utiliza a nivel mundial para conectarse a Internet y a los servidores web. Es compatible con las herramientas estándar para analizar el funcionamiento de la red.

Un inconveniente de TCP/IP es que es más difícil de configurar y de mantener que NetBEUI o IPX/SPX; además es algo más lento en redes con un volumen de tráfico medio bajo. Sin embargo, puede ser más rápido en redes con un volumen de tráfico grande donde haya que enrutar un gran número de tramas.

El conjunto TCP/IP se utiliza tanto en campus universitarios como en complejos empresariales, en donde utilizan muchos enrutadores y conexiones a mainframe o a ordenadores UNIX, así como también en redes pequeñas o domésticas, e incluso en teléfonos móviles y en domótica.

HIISTORIA DEL PROTCOLO TCP/IP

La Familia de Protocolos de Internet fueron el resultado del trabajo llevado a cabo por la Agencia de Investigación de Proyectos Avanzados de Defensa (DARPA por sus siglas en inglés) a principios de los 70. Después de la construcción de la pionera ARPANET en 1969 DARPA comenzó a trabajar en un gran número de tecnologías de transmisión de datos. En 1972, Robert E. Kahn fue contratado por la Oficina de Técnicas de Procesamiento de Información de DARPA, donde trabajó en la comunicación de paquetes por satélite y por ondas de radio, reconoció el importante valor de la comunicación de estas dos formas. En la primavera de 1973, Vint Cerf, desarrollador del protocolo de ARPANET, Network Control Program(NPC) se unió a Kahn con el objetivo de crear una arquitectura abierta de interconexión y diseñar así la nueva generación de protocolos de ARPANET.

Para el verano de 1973, Kahn y Cerf habían conseguido una remodelación fundamental, donde las diferencias entre los protocolos de red se ocultaban usando un Protocolo de comunicaciones y además, la red dejaba de ser responsable de la fiabilidad de la comunicación, como pasaba en ARPANET , era el host el responsable. Cerf reconoció el mérito de Hubert Zimmerman y Louis Pouzin, creadores de la red CYCLADES, ya que su trabajo estuvo muy influenciado por el diseño de esta red.

Con el papel que realizaban las redes en el proceso de comunicación reducido al mínimo, se convirtió en una posibilidad real comunicar redes diferentes, sin importar las características que éstas tuvieran. Hay un dicho popular sobre el protocolo TCP/IP, que fue el producto final desarrollado por Cerf y Kahn, que dice que este protocolo acabará funcionando incluso entre "dos latas unidas por un cordón". De hecho hay hasta una implementación usando palomas mensajeras, IP sobre palomas mensajeras, que está documentado en RFC 1149. [1] .[2]

Un ordenador denominado router (un nombre que fue después cambiado a gateway, puerta de enlace, para evitar confusiones con otros tipos de Puerta de enlace) esta dotado con una interfaz para cada red, y envía Datagramas de ida y vuelta entre ellos. Los requisitos para estos routers están definidos en el RFC 1812. [3]

Esta idea fue llevada a la práctica de una forma mas detallada por el grupo de investigación que Cerf tenía en Stanford durante el periodo de 1973 a 1974, dando como resultado la primera especificación TCP (Request for Comments 675,) [4] Entonces DARPA fue contratada por BBN Technologies, la Universidad de Stanford, y la University College de Londres para desarrollar versiones operacionales del protocolo en diferentes plataformas de hardware. Se desarrollaron así cuatro versiones diferentes: TCP v1, TCP v2, una tercera dividida en dos TCP v3 y IP v3 en la primavera de 1978, y después se estabilizó la versión TCP/IP v4 — el protocolo estándar que todavía se emplea en Internet.

En 1975, se realizó la primera prueba de comunicación entre dos redes con protocolos TCP/IP entre la Universidad de Stanford y la University College de Londres (UCL). En 1977, se realizó otra prueba de comunicación con un protocolo TCP/IP entre tres redes distintas con ubicaciones en Estados Unidos, Reino Unido y Noruega. Varios prototipos diferentes de protocolos TCP/IP se desarrollaron en múltiples centros de investigación entre los años 1978 y 1983. La migración completa de la red ARPANET al protocolo TCP/IP concluyó oficialmente el día 1 de enero de 1983 cuando los protocolos fueron activados permanentemente.[5]

En marzo de 1982, el Departamento de Defensa de los Estados Unidos declaró al protocolo TCP/IP el estándar para las comunicaciones entre redes militares.[6] En 1985, el Centro de Administración de Internet (Internet Architecture Board IAB por sus siglas en inglés) organizó un Taller de Trabajo de tres días de duración, al que asistieron 250 comerciales promocionando así el protocolo lo que contribuyó a un incremento de su uso comercial.

Kahn y Cerf fueron premiados con la Medalla Presidencial de la Libertad el 10 de noviembre de 2005 por su contribución a la cultura Americana.[7]

FAMILIA DE PROTOCOLOS DE INTERNET

La familia de protocolos de Internet es un conjunto de protocolos de red en los que se basa Internet y que permiten la transmisión de datos entre redes de computadoras. En ocasiones se le denomina conjunto de protocolos TCP/IP, en referencia a los dos protocolos más importantes que la componen: Protocolo de Control de Transmisión (TCP) y Protocolo de Internet (IP), que fueron los dos primeros en definirse, y que son los más utilizados de la familia. Existen tantos protocolos en este conjunto que llegan a ser más de 100 diferentes, entre ellos se encuentra el popular HTTP (HyperText Transfer Protocol), que es el que se utiliza para acceder a las páginas web, además de otros como el ARP (Address Resolution Protocol) para la resolución de direcciones, el FTP (File Transfer Protocol) para transferencia de archivos, y el SMTP (Simple Mail Transfer Protocol) y el POP (Post Office Protocol) para correo electrónico, TELNET para acceder a equipos remotos, entre otros.

El TCP/IP es la base de Internet, y sirve para enlazar computadoras que utilizan diferentes sistemas operativos, incluyendo PC, minicomputadoras y computadoras centrales sobre redes de área local (LAN) y área extensa (WAN).

TCP/IP fue desarrollado y demostrado por primera vez en 1972 por el Departamento de Defensa de los Estados Unidos, ejecutándolo en ARPANET, una red de área extensa de dicho departamento.

La familia de protocolos de Internet puede describirse por analogía con el modelo OSI (Open System Interconnection), que describe los niveles o capas de la pila de protocolos, aunque en la práctica no corresponde exactamente con el modelo en Internet. En una pila de protocolos, cada nivel soluciona una serie de problemas relacionados con la transmisión de datos, y proporciona un servicio bien definido a los niveles más altos. Los niveles superiores son los más cercanos al usuario y tratan con datos más abstractos, dejando a los niveles más bajos la labor de traducir los datos de forma que sean físicamente manipulables.

El modelo de Internet fue diseñado como la solución a un problema práctico de ingeniería.

El modelo OSI, en cambio, fue propuesto como una aproximación teórica y también como una primera fase en la evolución de las redes de ordenadores. Por lo tanto, el modelo OSI es más fácil de entender, pero el modelo TCP/IP es el que realmente se usa. Sirve de ayuda entender el modelo OSI antes de conocer TCP/IP, ya que se aplican los mismos principios, pero son más fáciles de entender en el modelo OSI.

El 1 de enero de 2010 el Protocolo TCP/IP cumplió 27 años.